Search

 
 
rss feed


Forums

pvcsnathan's rct archive :: Forums :: Games :: RollerCoaster Tycoon 3
 
<< Previous thread | Next thread >>
EazyCheeze's problem; includes DxDiag
Moderators: pvcsnathan
Author Post
EazyCheeze
Wed May 03, 2006 06:58pm
Member: 8
Joined: 3-May 06
Posts: 1

CoasterBeans: cb
Spent: cb
From the GameFAQs board:

Whenever I try to install, I get an "Internal Failure" with an unhandled exception: 0x80040707 . The installation proceeds, but I cannot proceed beyond the "Select Target Folder" stage, nor can I go back from it, strangely! I have Googled this number and gotten many potential solutions, but none of them work for me. Has anyone else got this problem and solved it, and if so what did you do?

My DxDiag:

------------------
System Information
------------------
Time of this report: 5/3/2006, 18:43:28
Machine name: CHEEZATORIUM
Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
Language: English (Regional Setting: English)
System Manufacturer: syx
System Model: D865GLC
BIOS: BIOS Date: 09/24/03 11:07:51 Ver: 08.00.09
Processor: Intel(R) Pentium(R) 4 CPU 3.00GHz (2 CPUs)
Memory: 766MB RAM
Page File: 358MB used, 1133MB available
Windows Dir: C:WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode

------------
DxDiag Notes
------------
DirectX Files Tab: The file system.dll is missing! You should reinstall DirectX to get the latest version.
Display Tab 1: The file nv4_disp.dll is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo'd driver from the hardware manufacturer.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Music Tab: No problems found.
Input Tab: No problems found.
Network Tab: The registry information for the DirectPlay application 'Forsaken' is missing or damaged. You should reinstall that application. The registry information for the DirectPlay application 'Re-Volt' is missing or damaged. You should reinstall that application.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (n/a)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (n/a)
DirectMusic: 0/5 (n/a)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: NVIDIA GeForce 6800 GT
Manufacturer: NVIDIA
Chip type: GeForce 6800 GT
DAC type: Integrated RAMDAC
Device Key: EnumPCIVEN_10DE&DEV_0045&SUBSYS_00000000&REV_A1
Display Memory: 256.0 MB
Current Mode: 1280 x 960 (32 bit) (85Hz)
Monitor: Plug and Play Monitor
Monitor Max Res: 1600,1200
Driver Name: nv4_disp.dll
Driver Version: 6.14.0010.8443 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail
Driver Date/Size: 4/5/2006 17:03:00, 3975936 bytes
WHQL Logo'd: No
WHQL Date Stamp: None
VDD: n/a
Mini VDD: nv4_mini.sys
Mini VDD Date: 4/5/2006 17:03:00, 3650528 bytes
Device Identifier: {D7B71E3E-4305-11CF-4B43-0A2000C2CB35}
Vendor ID: 0x10DE
Device ID: 0x0045
SubSys ID: 0x00000000
Revision ID: 0x00A1
Revision ID: 0x00A1
Video Accel: ModeMPEG2_A ModeMPEG2_B ModeMPEG2_C ModeMPEG2_D
Deinterlace Caps: {212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
{212DC724-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive
{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch
Registry: OK
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled
DDraw Test Result: Not run
D3D7 Test Result: Not run
D3D8 Test Result: Not run
D3D9 Test Result: Not run

-------------
Sound Devices
-------------
Description: SoundMAX Digital Audio
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCIVEN_8086&DEV_24D5&SUBSYS_E0028086&REV_02
Manufacturer ID: 1
Product ID: 100
Type: WDM
Driver Name: smwdm.sys
Driver Version: 5.12.0001.3713 (English)
Driver Attributes: Final Retail
WHQL Logo'd: Yes
Date and Size: 8/20/2003 12:25:56, 593152 bytes
Other Files:
Driver Provider: Analog Devices
HW Accel Level: Full
Cap Flags: 0xF5F
Min/Max Sample Rate: 100, 48000
Static/Strm HW Mix Bufs: 33, 32
Static/Strm HW 3D Bufs: 33, 32
HW Memory: 0
Voice Management: Yes
EAX(tm) 2.0 Listen/Src: Yes, Yes
I3DL2(tm) Listen/Src: Yes, Yes
Sensaura(tm) ZoomFX(tm): Yes
Registry: OK
Sound Test Result: Not run

Description: Modem #0 Line Playback (emulated)
Default Sound Playback: No
Default Voice Playback: No
Hardware ID:
Manufacturer ID: 1
Product ID: 81
Type: Emulated
Driver Name:
Driver Version:
Driver Attributes:
WHQL Logo'd:
Date and Size:
Other Files:
Driver Provider:
HW Accel Level: Full
Cap Flags: 0x0
Min/Max Sample Rate: 0, 0
Static/Strm HW Mix Bufs: 0, 0
Static/Strm HW 3D Bufs: 0, 0
HW Memory: 0
Voice Management: No
EAX(tm) 2.0 Listen/Src: No, No
I3DL2(tm) Listen/Src: No, No
Sensaura(tm) ZoomFX(tm): No
Registry: OK
Sound Test Result: Not run

---------------------
Sound Capture Devices
---------------------
Description: SoundMAX Digital Audio
Default Sound Capture: Yes
Default Voice Capture: Yes
Driver Name: smwdm.sys
Driver Version: 5.12.0001.3713 (English)
Driver Attributes: Final Retail
Date and Size: 8/20/2003 12:25:56, 593152 bytes
Cap Flags: 0x41
Format Flags: 0xCCC

Description: Modem #0 Line Record (emulated)
Default Sound Capture: No
Default Voice Capture: No
Driver Name:
Driver Version:
Driver Attributes:
Date and Size:
Cap Flags: 0x20
Format Flags: 0x0

-------------

My notes:

System.dll is missing: It must not be important, as not even the web-setup of DirectX would replace it.
No WHQL digital signature: I'm using the latest BETA drivers from Nvidia. But even the WHQL-signed ones give me this error.

-------------

What I have tried:

Installing on another computer (my dad's business computer); no error message, but not going to install there since no decent video card

Doing a Diagnostic Startup as set in msconfig.exe; error.

Rebooting in safe-mode to install; error.

Correcting User Shell Folder registry entries (they were correct).

Setting Compatibility Mode for RCT3's setup,exe to Windows 98 / Me; the installer did not run, and as I looked in Task Manager, many setup.exe processes started, none of which showed anything else on the screen.

----------------

What I can't do:

Reformat/reinstall Windows. I've invested too much time and effort to lose a lot of stuff.

----------------

What I have learned about my problem:

It's a DLL malfunction, according to some sources. But it's not in the installation program itself, as the installer did not show an error when I started it on my other computer. What I need to do, I think, is find the right DLL and reset it, probably by a few regsvr32 commands.

----------------

What I definitively know can fix my problem:

???? That's where you come in, Nathan!

----------------

Thanks a lot,
Wade aka EazyCheeze
Back to top
RAZGRIZ10000
Sun Sep 16, 2007 08:05pm
Member: 32
Joined: 17-Oct 06
Posts: 1047

CoasterBeans: 5347cb
Spent: 21512cb
No replys here ether
Back to top
pvcsnathan
Sun Sep 16, 2007 11:01pm
"Hello, Domo!"

Member: 1
Joined: 1-Aug 05
Posts: 1529

CoasterBeans: 2946cb
Spent: 38857cb
RAZGRIZ10000 wrote ...

No replys here ether


If you look in the original thread there are replies. For whatever reason, the replies didn't carry over through the conversion from phpbb2 to e107.

[ Edited Sun Sep 16, 2007 11:02pm ]
Back to top
Website
 

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System


 




Powered by e107.

© 2005-2008 Nathan Skelton



By using this site you agree to our Terms of Service.


Render time: 0.0632 sec, 0.0155 of that for queries. DB queries: 50. Memory Usage: 2,345kB